BOJ: 6438 Reverse Text

1 분 소요

문제

In most languages, text is written from left to right. However, there are other languages where text is read and written from right to left. As a first step towards a program that automatically translates from a left-to-right language into a right-to-left language and back, you are to write a program that changes the direction of a given text.

입력

The input file contains several test cases. The first line contains an integer specifying the number of test cases in the file. Each test case consists of a single line of text which contains at most \(70\) characters. However, the newline character at the end of each line is not considered to be part of the line.

출력

For each test case, print a line containing the characters of the input line in reverse order.

예제 입력 1

3
Frankly, I don't think we'll make much
money out of this scheme.
madam I'm adam

예제 출력 1

hcum ekam ll'ew kniht t'nod I ,ylknarF
.emehcs siht fo tuo yenom
mada m'I madam


코드

#include <bits/stdc++.h>

using namespace std;

int main(void) {
    ios_base::sync_with_stdio(false); cin.tie(NULL);
    int t;
    char str[71];

    cin>>t;

    cin.ignore(numeric_limits<streamsize>::max(), '\n');

    for(int i=0; i<t; i++) {
        int j;

        cin.getline(str, 71);

        j = strlen(str);

        while(j != 0) {
            cout<<str[--j];
        }

        cout<<'\n';
    }
        
    return 0;
}

Reference

BOJ

태그:

카테고리:

업데이트:

댓글남기기